profile="http://gmpg.org/xfn/11"> Как получить все значения в списке значений в 1С 8.2, 8.3? | Разработчику о работе с 1С:Предприятие, Pascal, Паскаль

Как получить все значения в списке значений в 1С 8.2, 8.3?

Как получить все значения в списке значений в 1С 8.2, 8.3?

Пример:

Процедура КакПолучитьВсеЗначенияВСпискеЗначений()
	спсЗнач=Новый СписокЗначений;
	СтрокаЗнач="Для примера";//занесем эту строку в список значений по символам
	КолСимволов=СтрДлина(СтрокаЗнач);
	Для л=1 По КолСимволов Цикл
		спсЗнач.Добавить(Сред(СтрокаЗнач,л,1));
	КонецЦикла;

	//вывод данных из списка значений

	// первый вариант
	Для каждого СтрТЗ Из спсЗнач Цикл
		Сообщить("Первый вариант: "+СтрТЗ.Значение);
	КонецЦикла;

	//второй вариант
	КолЗначений=спсЗнач.Количество();
	Для л=1 По КолЗначений Цикл
		Сообщить("Второй вариант: "+ спсЗнач[л-1]);
	КонецЦикла;

	//третий вариант
	КолЗначений=спсЗнач.Количество();
	Для л=1 По КолЗначений Цикл
		Сообщить("Третий вариант: "+ спсЗнач.Получить(л-1));
	КонецЦикла;

КонецПроцедуры

Ответ на вопрос: Как получить все значения в списке значений в 1С 8.2, 8.3?

Комментарии запрещены.