profile="http://gmpg.org/xfn/11"> Функция Формат (ТекЗначение, ФорматнаяСтрока) в 1С. | Разработчику о работе с 1С:Предприятие, Pascal, Паскаль

Функция Формат (ТекЗначение, ФорматнаяСтрока) в 1С.

Функция Формат (ТекЗначение, ФорматнаяСтрока) в 1С.

Код для числа:
1.

Процедура ФункцииФорматВ1С()
	ТекЗначение = "1452.24";
	ФорматнаяСтрока="ЧЦ=10; ЧДЦ=2";
	ТекЗначениеФормат =  Формат(ТекЗначение,ФорматнаяСтрока);
	Сообщить("Формат: "+ТекЗначениеФормат);
КонецПроцедуры

Результат:

Формат: 1452.24

ТекЗначение = «-1452.24»;

ФорматнаяСтрока="ЧЦ=10; ЧО=2";
ТекЗначениеФормат =  Формат(ТекЗначение,ФорматнаяСтрока);
Сообщить("Формат: "+ТекЗначениеФормат);

Результат:

Формат: -1452.24

3.

ТекЗначение = "-145247.24";
ФорматнаяСтрока="ЧЦ=10; ЧДЦ=2; ЧГ=3,0";
ТекЗначениеФормат =  Формат(ТекЗначение,ФорматнаяСтрока);
Сообщить("Формат: "+ТекЗначениеФормат);

Код для даты:
1.

Процедура ФункцииФормат1С()
	ТекЗначение = Дата("20170301235420");
	ФорматнаяСтрока="ДЛФ=DDT";
	ТекЗначениеФормат =  Формат(ТекЗначение,ФорматнаяСтрока);
	Сообщить("Формат: "+ТекЗначениеФормат);
КонецПроцедуры

Результат:

Формат: 1 марта 2017 г. 23:54:20

2.

Процедура ФункцииФормат1С()
	ТекЗначение = Дата("20170301235420");
	ФорматнаяСтрока="ДФ=dd.MM.yyyy";
	ТекЗначениеФормат =  Формат(ТекЗначение,ФорматнаяСтрока);
	Сообщить("Формат: "+ТекЗначениеФормат);
КонецПроцедуры

Результат:

Формат: 01.03.2017

3.

Процедура ФункцииФормат1С()
ТекЗначение = Дата(«20170301235420»);
ФорматнаяСтрока=«ДФ=yyyy-MM-dd»;
ТекЗначениеФормат = Формат(ТекЗначение,ФорматнаяСтрока);
Сообщить(«Формат: «+ТекЗначениеФормат);
КонецПроцедуры

Результат:
Формат: 20170301

Комментарии запрещены.