profile="http://gmpg.org/xfn/11"> Режим записи документов в 1С. | Разработчику о работе с 1С:Предприятие, Pascal, Паскаль

Режим записи документов в 1С.

Режим записи документов в 1С.
Существуют три набора режима записи документов в 1С.
Первый: РежимЗаписиДокумента.Запись. Документ сохраняется в информационной базе без изменения проведения, без изменений движений по регистрам.
Код:

Процедура РежимЗаписиДокументв1С()
	Док=ВыбранныйДокумент;
	ДокументОбъектЛи=Док.ПолучитьОбъект();
	ДокументОбъектЛи.Контрагент=Справочники.Контрагенты.НайтиПоКоду("000000004");//меняем Контрагента
	//При записи контрагент меняется в документе, но в движениях остается старый контрагент.
	ДокументОбъектЛи.Записать(РежимЗаписиДокумента.Запись)
КонецПроцедуры

Второй: РежимЗаписиДокумента.Проведение. Документ сохраняется в информационной базе и изменяются все движения по документу (изменяются регистры), то есть документ проводится.
Код:

Процедура РежимЗаписиДокументв1С()
	Док=ВыбранныйДокумент;
	ДокументОбъектЛи=Док.ПолучитьОбъект();
	ДокументОбъектЛи.Контрагент=Справочники.Контрагенты.НайтиПоКоду("000000004");//меняем Контрагента
	//При проведении контрагент меняется в документе и в движениях.
	ДокументОбъектЛи.Записать(РежимЗаписиДокумента.Проведение)
КонецПроцедуры

Третий: РежимЗаписиДокумента.ОтменаПроведения. При отмене проведения документ сохраняется, все движения отменяются.
Код:

Процедура РежимЗаписиДокументв1С()
Док=ВыбранныйДокумент;
ДокументОбъектЛи=Док.ПолучитьОбъект();
ДокументОбъектЛи.Контрагент=Справочники.Контрагенты.НайтиПоКоду(«000000030»);//меняем Контрагента
//При отмене проведения контрагент меняется в документе и сохраняется, все движения отменяются.
ДокументОбъектЛи.Записать(РежимЗаписиДокумента.ОтменаПроведения)
КонецПроцедуры

Стоит посмотреть:
Выбрать документы без запроса
Как записать документ по ссылке в 1С:Предприятие 8.0,8.2,8.3?
Как перебрать строки в таблице значений?

Комментарии запрещены.