profile="http://gmpg.org/xfn/11"> Список значений на форме в 1С 8.2, 8.3. Выбор одного флажка. Картинки на форме. | Разработчику о работе с 1С:Предприятие, Pascal, Паскаль

Список значений на форме в 1С 8.2, 8.3. Выбор одного флажка. Картинки на форме.

Список значений на форме в 1С 8.2, 8.3. Выбор одного флажка. Картинки на форме.

Разместим на форме  элемент формы ПолеСписка.
Список значений на форме с флажками и рисунками
Код:

Процедура ПриОткрытии()
	// Вставить содержимое обработчика.
	ПолеСписка1.Добавить("ПровестиДокумент","Провести документ",Истина,БиблиотекаКартинок.Провести);
	ПолеСписка1.Добавить("ОтменитьПроведениеДокумента","Отменить проведение документа",Ложь,БиблиотекаКартинок.ОтменаПроведения);
	ПолеСписка1.Добавить("ИмпортироватьДокумент","Импортировать документ",Ложь,БиблиотекаКартинок.Вперед);
КонецПроцедуры
 

Процедура ПолеСписка1ПриИзмененииФлажка(Элемент)
	// Вставить содержимое обработчика.
	//вариант когда должна быть только одна метка в списке значений на форме
	ТекущаяСтрока = Элемент.ТекущаяСтрока;
	Если ТекущаяСтрока.Пометка Тогда
		Для Каждого ЭлемСписка Из ПолеСписка1 Цикл   //перебираем элементы списка
			Если ЭлемСписка.Пометка И ЭлемСписка <> ТекущаяСтрока Тогда  // удаляем все пометки, кроме выбранной
				ЭлемСписка.Пометка = Ложь;
			КонецЕсли;
		КонецЦикла;
	КонецЕсли;
КонецПроцедуры

Таким образом можно создать список значений на форме в 1С с возможностью выбора одного флажка и картинки.
Список формы в режиме 1С Предприятие

Комментарии запрещены.