profile="http://gmpg.org/xfn/11"> Как изменить запись в непериодическом, независимом регистр сведений в 1С Предприятие 8.2, 8.3? | Разработчику о работе с 1С:Предприятие, Pascal, Паскаль

Как изменить запись в непериодическом, независимом регистр сведений в 1С Предприятие 8.2, 8.3?

Как изменить запись в непериодическом, независимом регистр сведений в 1С Предприятие 8.2, 8.3?

Часто требуется изменить данные в регистре сведений.

Процедура КакИзменитьЗаписьВНепериодическомНезависимомРегистрСведений1СПредприятие82()
	НЗМестаХраненияНом = РегистрыСведений.МестаХраненияНоменклатуры.СоздатьНаборЗаписей();
	НЗМестаХраненияНом.Отбор.Номенклатура.Установить(Справочники.Номенклатура.НайтиПоКоду("00000000036"));
	НЗМестаХраненияНом.Отбор.Склад.Установить(Справочники.Склады.НайтиПоКоду("000000010"));
	НЗМестаХраненияНом.Отбор.Приоритет.Установить(Справочники.Склады.НайтиПоКоду("000000010"));
	НЗМестаХраненияНом.Прочитать();
	Для каждого СтрТЗ Из НЗМестаХраненияНом Цикл
		Сообщить(" "+  СтрТЗ.МестоХранения); //было
		СтрТЗ.МестоХранения=Справочники.МестаХранения.НайтиПоКоду("000000035");//стало
	КонецЦикла;
	НЗМестаХраненияНом.Записать(Истина);
КонецПроцедуры

Процедура КнопкаВыполнитьНажатие(Кнопка)
	КакИзменитьЗаписьВНепериодическомНезависимомРегистрСведений1СПредприятие82();
КонецПроцедуры

Комментарии запрещены.