profile="http://gmpg.org/xfn/11"> Как изменить значение реквизита документа 1С? | Разработчику о работе с 1С:Предприятие, Pascal, Паскаль

Как изменить значение реквизита документа 1С?

Как изменить значение реквизита документа 1С?
Часто возникает потребность изменить какое-то значение в отдельном реквизите. И не в одном документе, в в нескольких документах. Возможно использовать запрос.
Например:

Процедура ИзменитьЗначениеВРеквизите()
	Запрос = Новый Запрос;
	Запрос.Текст =
	"ВЫБРАТЬ
	|	ЗаказПокупателя.ДатаОплаты,
	|	ЗаказПокупателя.Ссылка
	|ИЗ
	|	Документ.ЗаказПокупателя КАК ЗаказПокупателя
	|ГДЕ
	|	ЗаказПокупателя.Контрагент = &Контрагент
	|	И ЗаказПокупателя.Дата >= &Дата";
	Запрос.УстановитьПараметр("Контрагент",ВыбКонтрагент);
	Запрос.УстановитьПараметр("Дата",НачалоГода(ТекущаяДата()));
	РезультатЗапроса = Запрос.Выполнить();

	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		ОбДок=ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект();
		ОбДок.ДатаОплаты=КонецГода(ТекущаяДата());//изменение реквизита
		ОбДок.Записать(РежимЗаписиДокумента.Проведение);
		Сообщить(" "+ОбДок);
	КонецЦикла;
КонецПроцедуры

Процедура КнопкаВыполнитьНажатие(Кнопка)
	// Вставить содержимое обработчика.
	ИзменитьЗначениеВРеквизите();
КонецПроцедуры

В статье был рассмотрен вопрос:
Как изменить значение реквизита документа 1С?

Комментарии запрещены.