profile="http://gmpg.org/xfn/11"> Как загрузить информацию из Excel в 1С:Предприятие? При помощи COMObject. Вариант 1. | Разработчику о работе с 1С:Предприятие, Pascal, Паскаль

Как загрузить информацию из Excel в 1С:Предприятие? При помощи COMObject. Вариант 1.

Как загрузить информацию из Excel в 1С:Предприятие? При помощи COMObject. Вариант 1.
Часто в практике 1С программиста возникает задача загрузки данных из Экселя.
Вариант 1:

Процедура СоединениеExcel(ОшибкаСоединения,ТаблицаЭксель)
	ОшибкаСоединения = 1;
	Попытка
		ТаблицаЭксель = Новый COMObject ("Excel.Application");
		ОшибкаСоединения = 0;
		Сообщить ("Соединение установлено");
	Исключение
		Сообщить ("Нет соединения, возможно не установлен Excel");
		ОшибкаСоединения = 1;
	КонецПопытки;
КонецПроцедуры

Процедура ЗагрузитьИзExcel()
	Перем ОшибкаСоединения,ТаблицаЭксель;
        СоединениеExcel(ОшибкаСоединения,ТаблицаЭксель);
	Если ОшибкаСоединения=1 Тогда
		Возврат;
	КонецЕсли;
	ИмяФайла="C:\Temp\Тестовая книга.xlsx";
	ТаблицаЭксель.Workbooks.Open(ИмяФайла);
	ЛокЗнач=ТаблицаЭксель.Cells("1,1").Value;
	Сообщить(" "+ЛокЗнач);
        ТаблицаЭксель.Quit();
	Сообщить ("Соединение завершено");
	ТаблицаЭксель=0;
КонецПроцедуры

В первой процедуре устанавливаем соединение с объектом Excel. Во второй происходить загрузка, отсоединение от com Объекта Excel.

ТаблицаЭксель.Quit();

Данный способ называется OLE соединение. Существует еще один вариант загрузки из Экселя.

Комментарии запрещены.